Diesel F150 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
On my 2019 Platinum with 2500 miles I've had the dreaded Adaptive Cruise Control Sensor Blockage warning on for the past 5 days and can't get it to go away.


- I've cleaned the bumper in front of the sensor.
- I've cleaned the sensor it self.
- I've checked the sensor plug for proper connection and water penetration.
- The sensor is properly mounted in the OEM bumper and does not wiggle or move.
- I've even pulled the bumper cover off and driven down the hwy with it uncovered, to no avail.



This pisses me off because one of the main reasons I got this truck was for the adaptive cruise control. Sucks to be out of a truck for a few days just so they can order and replace the sensor.


Any other suggestions?




Thanks
 

·
Registered
Joined
·
24 Posts
Honestly since this is a think that can/will affect all F150s not just diesel ones I might ask on f150forum - might have more luck
 

·
Super Moderator
Joined
·
766 Posts
Buddy got a brand new ranger and he had to have the radar replaced already. All good now.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I finally figured it out.


In a nut shell I had my truck leveled and the sensor needed to be adjusted. It was pointing too high and needed to be adjusted down a bit so that the face of the radar is perpendicular to the ground.
 

·
Super Moderator
Joined
·
434 Posts
@danbart - makes a lot of sense in retrospect! Assuming this is not specific to F150 PS Diesels...
Glad you got this sorted out and let this be a warning to anyone lifting or leveling their trucks!
 
1 - 7 of 7 Posts
Top