Diesel F150 Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
Hi, anyone having issues with the 2018 touchscreen nav/radio? Mine is sometimes slow to respond and "no GPS" logo? It works most of the time with no black screen issues, but occasionally it has issues. Even the compass can stay stuck? I disconnected the battery and it helped, along with turning off WI-fi and Automatic Updates. Thanks for input.
 

·
Premium Member
Joined
·
330 Posts
My 2018 is working as designed, hope it continues. I did the update to 19205 and had some real issues with that ordeal but now all is good. I hear the newer APIMs are having warranty issues and several have been replaced. Maybe take photos of the issues and visit the dealer? Hope yours gets straightened out soon!
 

·
Super Moderator
Joined
·
809 Posts
Yes I replaced mine myself, bought off a guy on Ebay. They are known to go bad in all ford vehicles.
 

·
Registered
Joined
·
13 Posts
That sounds like the normal symptoms when the APIM is on its way out. It doesn't often black out but you get no GPS, slow response to inputs and, usaully the first evidence, bluetooth starts cutting in and out in the middle of calls. i have the issue on my 16 and it took 3 visits and 5 months before Ford would replace it as they could not get a code - even though they could see it with their own eyes! go figure.....
 

·
Administrator
Joined
·
522 Posts
@wreedsvt - any reason you didn't have Ford replace it at their cost under your 3yr/36K bumper-to-bumper warranty?
 

·
Super Moderator
Joined
·
809 Posts
@wreedsvt - any reason you didn't have Ford replace it at their cost under your 3yr/36K bumper-to-bumper warranty? Have you deleted?
I am weird and don't like them messing with my truck. I took it apart and put it back together very delicately.
 

·
Registered
Joined
·
12 Posts
Mine went bad, It would lock up and be really slow. Ford first tried to reload it and then later they just replaced it.
 

·
Super Moderator
Joined
·
809 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #11
I upgrade to latest software and still has "lag/freezing", looks like APIM replacement. Dang, first EGR now this!
 

·
Super Moderator
Joined
·
809 Posts
I upgrade to latest software and still has "lag/freezing", looks like APIM replacement. Dang, first EGR now this!
Yeah :( mine did same thing. Time to replace it unfortunately.
 

·
Super Moderator
Joined
·
809 Posts
Its a issue with EVERY FORD vehicle with Sync.

No. Pop the bezel off, remove screen and module is right there screwed to back of screen.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #15
My dad has a 2017 F350 and his died too.



That's good, but with my past experience with Ford dealer I am still leery of their work. BUT, this APIM is not working so I must do what has to be done. Thanks my friend.
 

·
Registered
Joined
·
145 Posts
Right my screen w3ht black once and would not come back on fir a while thinking it was a battery issue since it was cold and then when I started the trucking took 15 minutes to come back up
 

·
Registered
Joined
·
11 Posts
I’ve been experiencing the same issues for about 3 months. It’s a daily work truck and I haven’t had the chance to get it into the dealer to let them tinker with a non-crucial repair. Same symptoms: super slow response, slow start up, doesn’t recognize phone being plugged in, no GPS. Sometimes it work like it should and other times it doesn’t. It’s very annoying that I’ve only had the truck for 9 months before it started acting up. It was one of my major concerns about buying a vehicle that was highly integrated and mostly digital. Give me my old Tacoma’s radio back with real buttons. Worked every time. Ugh!
 

·
Registered
Joined
·
1 Posts
APIM issues

I had issues with my 2014 F150 and I replaced it myself I ordered the replacement from 4dtech (I cant post the link) but google it their customer service is great. I agree with the other posts if its still under warranty have dealer replace it. This is a known issue with the APIM for the last decade FYI.
 

·
Registered
Joined
·
43 Posts
2019 F150 3.0L with 22,000 miles
Dealership just replaced mine under warranty. Service manager told me this is very common but good news he said! After replacing them he has not had one come back with the same issue. haha.
 
1 - 19 of 19 Posts
Top