Diesel F150 Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 · (Edited)
I was on a road trip yesterday and the Amber wrench icon came on while driving at 70MPH. Message said check manual. No problems noted with engine or transmission. Pulled over. Checked manual and it wasn’t much help. Shut it off and recranked but icon was still there. Finished driving home with no issues with motor or transmission. I noticed the transmission gear indicator on the tach gauge is missing. This morning, the wrench icon is gone, but gear indication is still gone. I can’t get to dealer until next week. Anybody know if it’s just an indication problem or something more major that I need to be worried about? Thanks!
 

·
Registered
Joined
·
40 Posts
.........hum, at risk of being dumber then usual, I picked up my King Ranch diesel this morning, and does the gear indicator not only show when in M ?
 

·
Administrator
Joined
·
860 Posts
Click the Up/Down on the gear shift while in Drive to get it back.
 

·
Registered
Joined
·
399 Posts
wreedsvt has provided the correct input. I researched this as my gear shift indicator has gone dark on me before, and if it ever does, a press of the "+" on the gear shifter brings it right back on the display.

As far as the wrench icon goes, I have not seen that come up yet on my F150 Power Stroke.

In my opinion, the above two items are likely unrelated to each other.
 

·
Administrator
Joined
·
860 Posts
Wrench is bad. Get Forscan and pull codes.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
Got a message on FordPass about Powertrain /reduced power. ForScan showed a code for the same problem. Going to dealership this week. Disappointing after only 2500 miles. Thanks for the inputs.
 

·
Administrator
Joined
·
860 Posts
So whats the code?
 

·
Administrator
Joined
·
860 Posts
Torque Converter Cluster Solenoid.

Probably bad solenoid or sensor.
 
G

·
p1744 code is the excessive slippage detected by pcm monitoring hydraulic pressures within the trans.
Code could be caused by more than one problem.
Low fluid
high fluid temp
low pump output pres.
leaking torque converter seals (pressure within)
Bad tft (trans fluid temp sensor)
Bad torque converter clutch(TCC)
Loose valve body bolts within the trans pan
could also be a loose connection electrically at the transmission harness
 

·
Administrator
Joined
·
860 Posts
Hope it comes back with a simple fix!
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #15 ·
Thanks! Dealer says it’s the valve body. Not sure that qualifies as a simple fix. Hopefully parts this afternoon and half a day to fix.
 

·
Administrator
Joined
·
860 Posts
If it a good dealer, should not be too big of issue.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #17 ·
Got truck back. It drives OK so far. According to receipt, the TCC stuck and the Regulator valve was binding in the bore. They replaced main control assembly. Not a mechanic, so not sure what that all means.
 

·
Administrator
Joined
·
782 Posts
@Scott Barron - thanks for feeding back with specific details on your fix (even if you don't understand the terms)

Sounds like too tight of a tolerance between the piston/plunger and cylinder in this TCC valve/solenoid, that was binding things up and messing up how the Torque Converter should work.

This type of feedback is great so if other owners get the same code, they will have some idea as to what the problem might be = we are building up a knowledge base here...
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #19 ·
My pleasure. I appreciate all the knowledge to be gained on here and all the folks that provide it👍
 

·
Administrator
Joined
·
860 Posts
Glad you got it fixed! What dealer did the work?
 
1 - 20 of 21 Posts
Top